iowolfet

Bild des Benutzers rettichschnidi

Das Spiel

Iowolfet ist ein Open Source-Projekt, welches auf dem von ID Software freigegebenen Quellcode von Wolfenstein: Enemy Territory aufbaut. Zu beachten ist, dass es sich um den originalen Code handelt. Somit sind keine Patches oder Verbesserungen in dem Mercurial Zweig. Spieler sollten lieber OpenET benutzen.

Sourcecode auschecken

Mittels Mercurial kann der Code ausgecheckt werden

hg clone http://hg.ioquake.org/enemyterritory/

Weitere Infos

Wer sich für das Projekt interessiert, der wird derzeit im Channel #iowolfet auf Freenode am besten informiert.

ET-Xreal

ET-Xreal ist ein weiteres Projekt zur Weiterentwicklung der freigegebenen Quelltexte. Folgende Features wurden bereits umgesetzt:

  • ported XreaL renderer to src/engine/rendererGL3/
  • rewrote .mdm/.mdx code to be GPU accelerated
  • rewrote .md3/.mdc code to be GPU accelerated
  • added support for Linux 64-bit
  • replaced Linux sound backend with SDL
  • added .avi recorder from ioquake3 including sound support
  • added new ETXMap bsp compiler based on NetRadiant's q3map2
  • added new ETXRadiant level editor based on DarkRadiant

ET-Xreal snapshot

Theoretisch kann man den Snapshot von der Sourceforge Seite benutzen und in seinem ET Ordner entpacken und damit spielen. Bei mir hat das aber nicht geklappt.

ET-Xreal kompilieren

Zuerst müssen ein paar Abhägnigkeiten installiert werden:

apt-get install libcurl4-gnutls-dev scons libcurl-openssl-dev libsdl1.2-dev libxxf86dga-dev libxxf86vm-dev libglu1-mesa-dev

Nun holt man sich die Quellen:

git clone --recursive git://xreal.git.sourceforge.net/gitroot/xreal/ET-XreaL

Um die Sourcen zu bauen:

cd ET-XreaL
make

ET-Xreal spielen

Um OpenET zu starten und die neuen Features zu nutzen muss man eine vollständige Installation von ET auf seinem Rechner haben.
Die auf dem Holarse FTP liegende Version von 2.60 ist ausreichend, man benötigt nicht den 2.60b Patch da dieser nur die Executeable verändert und bei Open ET sowieso nutzlos wäre.

Damit man Open ET spielen kann muss man den Inhalt des "etmain" Ordner von der orginalen ET installation in den "etmain" Order von Open ET kopieren, dann kann man Open ET starten:

./etxreal

raedwulf-et

raedwulf-et ist ein anderer Fork der GPL Sourcen von ET. Nach Aussagen von raedwulf ist sein Fork eine Verquickung der orginal ET Sourcen mit ioquake3-Code Teilen und 64-bit support. Er will seinen Fork mit ET-Xreal von Tr3B vereinigen,will OpenGL 3 nutzbar machen und weiteren Inhalt einfügen. raedwulf entwickelt aktiv am Projekt.

Wenn die Verschmelzungen der beiden komplett ist wird das neue Projekt Openterritory heißen. Die Entwicklung daran hat noch nicht begonnen bzw ist wieder pausiert worden.

Features bisher von raedwulf-et:

  • ALSA und OpenAL support
  • 64 bit support
  • Ersetzen von SDL mit GLFW 3 für OpenGL 3 support
  • Bug fixes vom ET Source Code

Weitere Infos

Wer sich für das Projekt interessiert, der wird derzeit im Channel #iowolfet auf Freenode am besten informiert.

Screenshots und Videos
manuel
Bild des Benutzers manuel
Offline
Beigetreten: 19.05.2008
Beiträge: 245

Ich kann das Mercurial nicht testen:

hg clone http://hg.icculus.org/icculus/enemyterritory/
Abbruch: Anforderung '<?xml version="1.0" encoding="ascii"?>' nicht unterstützt!

Idden?

Danke :-D

comrad
Bild des Benutzers comrad
Offline
Beigetreten: 13.05.2008
Beiträge: 3433

Ja, am besten nimmst du den Befehl aus dem Artikel oben.

meldrian
Bild des Benutzers meldrian
Offline
Beigetreten: 12.05.2009
Beiträge: 1538

Hab was gefunden ***DOPPELPOST***

Here are some instructions I wrote to compile and run iortcw on 64-bit Ubuntu Linux. These instructions assume that you’re using a 64-bit version of Ubuntu 10.04 (Lucid Lynx), which is no longer the most recent version of Ubuntu. I’m sure that you can compile iortcw on newer versions of Ubuntu with few modifications, but I haven’t tried it. Using these instructions, the game runs great for me on Ubuntu Lucid.

The contents of this post are hereby placed into the public domain. I can’t provide support, so good luck!

How to install iortcw on 64-bit Linux (Ubuntu Lucid)

(1) Install build-time dependencies.

  1. for 64-bit systems:

sudo apt-get install nasm g++-multilib libstdc++6-4.1-dev libc6-dev-i386 g++ lib32stdc++6 libstdc++6 libxxf86dga-dev libxxf86dga1 libxxf86vm-dev mesa-common-dev libxext-dev

  1. 32-bit alternate: install the following packages:
  2. sudo apt-get install nasm g++-multilib g++ libstdc++6 libxxf86dga-dev libxxf86dga1 libxxf86vm-dev mesa-common-dev libxext-dev

(2) Define some build-path variables.

  1. the location in which you want to keep your installed copy of iortcw

export INSTALLDIR=~/local/iortcw

  1. a folder in which you will temporarily build iortcw

export STAGING=~/temp/iortcw-staging

mkdir -p ${STAGING}
cd ${STAGING}

(3) Grab the 32-bit versions of certain libraries and extract key files.

  1. use a command like the following
  2. in order to find out from where to download the packages:
  3. apt-get -d -y –reinstall –print-uris install libxxf86dga-dev libxxf86dga1 | sed -e ‘s/_amd64.deb/_i386.deb/g’
  4. alternately, you can download these 32-bit libraries using links
  5. similar to the below:
  6. http://packages.ubuntu.com/lucid/i386/libxxf86dga-dev/download
  7. http://packages.ubuntu.com/lucid/i386/libxxf86dga1/download
  8. the remainder of this HOWTO assumes that you have saved copies
  9. of these 32-bit .deb files from the above URLs to $DOWNLOAD

mkdir -p ${STAGING}/libs32
cd ${STAGING}/libs32
dpkg-deb -x ${DOWNLOAD}/libxxf86dga-dev_1.1.1-2_i386.deb .
dpkg-deb -x ${DOWNLOAD}/libxxf86dga1_1.1.1-2_i386.deb .

(4) Grab a copy of the iortcw source.

cd ${STAGING}
hg clone http://hg.ioquake.org/rtcw-sp/

(5) Patch the source to search the 32-bit version of key libraries.

(a) Edit the file Conscript-client:

vi ${STAGING}/rtcw-sp/src/unix/Conscript-client +154

(b) Manually apply the below patch. This changes the library search
path such that we use the special 32-bit libraries that we downloaded
and extracted in a previous step. Note that we’re adding a path
for ${STAGING}/libs32/usr/lib .

In this example, the path to $STAGING is
/home/username/temp/iortcw-staging , but you’ll need to change this.

— Conscript-client.original 2010-11-27 21:17:20.000000000 -0500

+++ Conscript-client 2010-11-27 21:14:32.000000000 -0500

@@ -151,7 +151,7 @@
. $BUILD_DIR . ‘/unix/jpeglib.a ‘
. $BUILD_DIR . ‘/unix/asmlib.a ‘
. $BUILD_DIR . ‘/unix/inlinelib.a ‘
– . ‘-L/usr/X11R6/lib -lX11 -lXext -lXxf86dga -lXxf86vm -ldl -lm’

+ . ‘-L/usr/X11R6/lib -L/home/username/temp/iortcw-staging/libs32/usr/lib -lX11 -lXext -lXxf86dga -lXxf86vm -ldl -lm’

);

@RENDERER_FILES = qw(

(6) Patch the source to work around a fatal string buffer overflow.
The quake3/rtcw source did not anticipate the number/size of the
GL_EXTENSIONS that would be advertised in 2010. In its unpatched state,
rtcw will overflow a buffer while filling a string with the list of
supported GL_EXTENSIONS, causing the game to crash. For our purposes,
we can suppress the list of GL_EXTENSIONS from the string and
avoid the overflow.

(a) Edit the file renderer/tr_init.c:

vi ${STAGING}/rtcw-sp/src/renderer/tr_init.c +847

(b) Manually apply the below patch:

— tr_init.c.original 2010-11-27 16:40:47.000000000 -0500

+++ tr_init.c 2010-11-27 22:44:15.000000000 -0500

@@ -844,7 +844,7 @@
ri.Printf( PRINT_ALL, “\nGL_VENDOR: %s\n”, glConfig.vendor_string );
ri.Printf( PRINT_ALL, “GL_RENDERER: %s\n”, glConfig.renderer_string );
ri.Printf( PRINT_ALL, “GL_VERSION: %s\n”, glConfig.version_string );
- ri.Printf( PRINT_ALL, “GL_EXTENSIONS: %s\n”, glConfig.extensions_string );

+ ri.Printf( PRINT_ALL, “GL_EXTENSIONS: (redacted)\n”, glConfig.extensions_string );

ri.Printf( PRINT_ALL, “GL_MAX_TEXTURE_SIZE: %d\n”, glConfig.maxTextureSize );
ri.Printf( PRINT_ALL, “GL_MAX_ACTIVE_TEXTURES_ARB: %d\n”, glConfig.maxActiveTextures );
ri.Printf( PRINT_ALL, “\nPIXELFORMAT: color(%d-bits) Z(%d-bit) stencil(%d-bits)\n”, glConfig.colorBits, glConfig.depthBits, glConfig.stencilBits );

(7) Build the iortcw source.

cd ${STAGING}/rtcw-sp/src/unix/
./cons — release

(8) Copy critical libraries into the build directory.

cd ${STAGING}/rtcw-sp/src/unix/release-x86-Linux-2.1/out
cp ${STAGING}/libs32/usr/lib/* .
chmod a+x lib*.*

(9) Create a 32-bit-library-friendly launcher script.

cd ${STAGING}/rtcw-sp/src/unix/release-x86-Linux-2.1/out
touch wolfsp-launcher.sh
chmod u+x wolfsp-launcher.sh
cat > wolfsp-launcher.sh< iortcw << EOF

  1. !/bin/bash

pushd ${INSTALLDIR}/
./wolfsp-launcher.sh \$@
popd
EOF

comrad
Bild des Benutzers comrad
Offline
Beigetreten: 13.05.2008
Beiträge: 3433

Am besten wär es, wenn das in den Artikel kommt, etwas aufbereitet natürlich.

manuel
Bild des Benutzers manuel
Offline
Beigetreten: 19.05.2008
Beiträge: 245

Das bezieht sich ja auf Wolfenstein und nicht auf die ET Version der sourcen. Ich bezweifele das sich das auf iowolfet anwenden lässt....

manuel
Bild des Benutzers manuel
Offline
Beigetreten: 19.05.2008
Beiträge: 245

Hi

So wie ich das sehen sind die Mercuial enemyteritorry sourcen die orginalen ohne irgendwelche patches.

Liege ich da richtig?

Danke

EDIT:

War grad im irc und der Mercuial code ist clean ohne irgendwelche patches, also eig nur für devs instressant...