Sound knackst, vermutlich ootb falsch konfiguriertes System. Hilfe?

9 Beiträge / 0 neu
Letzter Beitrag
meldrian
Bild des Benutzers meldrian
Offline
Beigetreten: 12.05.2009
Beiträge: 1649
Sound knackst, vermutlich ootb falsch konfiguriertes System. Hilfe?

Moin,

habe mir Ubuntu 10.04 LTS in der 64bit Variante auf mein System gezimmert und sehe mich bei vielen Spielen mit heftigen Soundproblemen konfrontiert.
Es klingt als seien die Boxen kaputt, der Sound knackt und knarrzt ziemlich heftig. Spielfreude kommt dabei nicht auf. An ein Arbeiten mit Headset ist bei der Geräuschkulisse gar nicht zu denken, darüber hinaus werden die Mikrofoneingänge nicht erkannt (Pegel zeigt bei angeschlossenem Mikrofon keinen Ausschlag, Audiorekorder startet nicht mit der Meldung über fehlerhafte Einstellungen zur Audio-Aufnahme)

Zur Info:

Board - Biostar TA75M.

Ausgabe von cat /proc/asound/cards

 0 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xfef40000 irq 16

Ausgabe von hwinfo --sound

19: PCI 14.2: 0403 Audio device                                 
  [Created at pci.318]
  UDI: /org/freedesktop/Hal/devices/pci_1022_780d
  Unique ID: 5Dex.SlBKXCS5Ys4
  SysFS ID: /devices/pci0000:00/0000:00:14.2
  SysFS BusID: 0000:00:14.2
  Hardware Class: sound
  Model: "AMD Audio device"
  Vendor: pci 0x1022 "AMD"
  Device: pci 0x780d 
  SubVendor: pci 0x1565 "Biostar Microtech Int'l Corp"
  SubDevice: pci 0x8225 
  Revision: 0x01
  Driver: "HDA Intel"
  Driver Modules: "snd_hda_intel"
  Memory Range: 0xfef40000-0xfef43fff (rw,non-prefetchable)
  IRQ: 16 (1461 events)
  Module Alias: "pci:v00001022d0000780Dsv00001565sd00008225bc04sc03i00"
  Driver Info #0:
    Driver Status: snd_hda_intel is active
    Driver Activation Cmd: "modprobe snd_hda_intel"
  Config Status: cfg=new, avail=yes, need=no, active=unknown

Freue mich über jede Hilfe und beantworte gerne weitere Fragen.

Guru
Bild des Benutzers Guru
Offline
Beigetreten: 15.04.2011
Beiträge: 45

Hi!

Das klingt ein wenig so, als wäre der Sound übersteuert. Hast du das mal mit dem alsamixer überprüft?
Eventuell musst du da auch den analogen Eingang aktivieren, um das Mikrofon zum Arbeiten zu bewegen.

Javafant
Bild des Benutzers Javafant
Offline
Beigetreten: 29.04.2011
Beiträge: 184

Eventuell ist die falsche Soundkarte aktiviert. Versuchs einfach mal mit einer anderen.

meldrian
Bild des Benutzers meldrian
Offline
Beigetreten: 12.05.2009
Beiträge: 1649

@Guru, habe mit den Einstellungen zu PCM ein bisschen herumgespielt. Selbst wenn ich den Wert sehr weit herunterdrehe (und die Boxen im Gegenzug so hoch das sie elektronisch surren), knackst es in den Spielen und bei der MP3 wiedergabe.

@Javafant, ich bin etwas unbedarft was manuelle Hardwarekonfiguration unter Linux angeht. Hast du eine Kurzanleitung oder Links wie vorzugehen ist? Ich probiere gerne etwas herum wenn es erfolgversprechend ist.

Ich hatte, da es sich um einen ALC892 Chipsatz (Realtek) handeln (soll laut Internet), ein Treiberpaket von RealTek aufgespielt. Das brachte mir via AlsaMixer zwar endlich mehr Einstellmöglichkeiten als "Master, PCM & Aufnahme" aber nicht die Lösung mit dem knacken und knarzen.

Danke für eure Antworten soweit. Freue mich über weitere,

Guru
Bild des Benutzers Guru
Offline
Beigetreten: 15.04.2011
Beiträge: 45

Was mich jetzt stutzig gemacht hat: Du hast ein AMD-System, aber es wird das Modul "snd_hda_intel" geladen. Dann bin ich auf folgendes gestoßen:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/573378
Der schlechte Sound könnte damit zusammenhängen. Dagegen spricht allerdings, dass der Treiber von Realtek nichts hilft.

Hast du irgendwelche Steckkarten installiert? Falls ja würde ich die probeweise mal umstecken.

Maar
Bild des Benutzers Maar
Offline
Beigetreten: 24.12.2010
Beiträge: 59

Also laut http://www.alsa-project.org/main/index.php/Changes_v1.0.21_v1.0.22 soll der hda-intel Treiber seit 2009 den ALC892 Chip unterstützen. Vielleicht verwendet dein Kernel eine ältere alsa Version, du könntest mal probieren die alsa-lib separat zu installieren. Die meisten Distributionen haben ja noch ein alsa-lib Paket als Alternative zum Kernel Modul.
Vielleicht könntest du auch mal die eine oder andere option zum alsa modul ausprobieren. Möglichkeiten zu dem Chipsatz stehen in der HD-Audio-Models.txt würde mich da mal am ALC888 orientieren, der scheint wohl identisch zum 892er zu sein.
Bei meiner Realtek Karte ALC662 hatte die option model=3stack-dig viel geholfen.

meldrian
Bild des Benutzers meldrian
Offline
Beigetreten: 12.05.2009
Beiträge: 1649

Ich habe mal ein sample wie ich im Moment alles höre (und noch viel schlimmer, die Aufnahme ist scheinbar nur leicht belastet).
http://www.file-upload.net/download-3644791/test.wav.html
Das ich mich so bescheiden anhöre liegt natürlich nur daran dass das System mit dem Sound rummurkst.
Hatte das noch nie jemand in der Art? Kann mir nicht vorstellen das ich so ein Sonderfall PC habe.

andreas
Bild des Benutzers andreas
Offline
Beigetreten: 07.06.2010
Beiträge: 109

probier mal :)

sudo add-apt-repository ppa:team-iquik/alsa; sudo add-apt-repository ppa:ubuntu-audio-dev/ppa; sudo apt-get update; sudo apt-get dist-upgrade; sudo apt-get install linux-alsa-driver-modules-$(uname -r) --force-yes; sudo apt-get --reinstall install alsa-base alsa-utils; killall pulseaudio; rm -r ~/.pulse*

reboot ..

meldrian
Bild des Benutzers meldrian
Offline
Beigetreten: 12.05.2009
Beiträge: 1649

@andreas:
Genial. Hab deine Befehlsformation gerade durchlaufen lassen. Egal ob Legends, der Startup Sound, Mp3, alles glasklar und in perfekter Wiedergabe.
Meinen herzlichsten Dank, du hast mir den heutigen Abend gerettet.
P.S.: Ich hab die neuste Version von ALSA installiert und Pulse vom System entfernt, oder? Wenn du dich berufen fühlst kannst du ja nochmal sagen was die einzelnen Befehle so bewirkt haben (sollten andere auf der Suche nach einer Lösung für das Gleiche Problem hier her gelangen).

Mastodon