Mad Max

Bild des Benutzers comrad

Mad Max wurde von Feral Interactive portiert und erschien am 20. Oktober 2016.

Die Systemvoraussetzungen nennen einen Intel i5 oder einen AMD FX8350 mit mindestens 8 GB RAM und einer 2GB Grafikkarte. Zudem wird SteamOS 2.0 oder Ubuntu 16.04 oder neuer unterstützt. Es wird mindestens eine NVIDIA 660ti-Karte verlangt, AMD oder Intel-GPUs werden nicht unterstützt.

Screenshots und Videos