Probleme mit ASUS A6T-AP005H (Shutdown / WLAN)

3 Beiträge / 0 neu
Letzter Beitrag
meldrian
Bild des Benutzers meldrian
Offline
Beigetreten: 12.05.2009
Beiträge: 1612
Probleme mit ASUS A6T-AP005H (Shutdown / WLAN)

Hallo miteinander,

ich habe ein älteres Notebook, Baujahr 2008, in die Hände bekommen, welches ich gerne mit Linux (teste aktuell openSUSE Leap 15) wieder flott machen möchte.
Stehe aktuell vor 2 Problemen.

1.
Das Gerät fährt nicht komplett herunter sondern hängt sich dabei auf. Dies habe ich schon bei weitere neueren Distributionen bemerkt. Ubuntu 14.04 zeigt dies bspw. nicht. Ich vermute es hängt mit dem verwendeten Kernel zusammen.
Beim Boot erscheint die Meldung "[0.040000] ..MP-Bios bug: 8254 timer not connected to IO-APIC". In wie weit das damit zu tun hat weiß ich nicht aber es sticht ins Auge.

2.
Das WLAN-Modul kann nicht verwendet werden.
LSPCI gibt aus:
03:03.0 Network Controller: Broadcom Limited BCM4318 [AirForce One 54G] 802.11g Wireless LAN Controller (rev 02)
Das Gerät scheint also erkannt, jedoch nicht angesprochen werden zu können. Alles was auf broadcom-firmware hinweist habe ich über yast installiert.

Während ich nebenher weiter zu den Auffälligkeiten recherchiere, freue ich mich über jede Rückmeldung zu den genannten Themen.

Guru
Bild des Benutzers Guru
Offline
Beigetreten: 15.04.2011
Beiträge: 45

Hi!

1. Hast du es mal mit der "noapic"-bootoption versucht? Dann ist APIC deaktiviert und zumindest die Meldung sollte nicht mehr kommen (dafür funktioniert auch das Teilen von Interrupts nicht mehr). Ob das Gerät dann ganz herunterfährt wird man sehen. ;)

2. Ich hatte den WLAN-Chip auch mal irgendwo und der war eher schwierig, soweit ich mich erinnern kann. Unter Ubuntu müsstest du die "bcmwl-kernel-source" de- und "firmware-b43-installer" installieren. Bei openSUSE werden das wahrscheinlich ähnliche Pakete sein. Dann mal mit "modprobe -r b43 bcma" die Module entfernen und mit "modprobe b43" das richtige Modul wieder laden. Sonst mal mit lsmod schauen was da momentan so broadcom-mäßiges geladen ist.

meldrian
Bild des Benutzers meldrian
Offline
Beigetreten: 12.05.2009
Beiträge: 1612

Die beiden Probleme hängen miteinander zusammen.
Ubuntu 14.04 installiert & komplett mit Updates versorgt (Kernel 4.4.0.128 ohne hwe) -> Herunterfahren/Neustart funktioniert.
"Zusätzliche Treiber installieren" und die Pakete für den Broadcom installiert -> Herunterfahren/Neustart funktioniert nicht mehr.
sudo apt-get remove --purge bcmwl-kernel-source -> Herunterfahren/Neustart funktioniert wieder.
Werde bei Zeiten noch ein wenig weiter testen.
Vermute, dass der Broadcom-Chip unter aktuelleren Distributionen automatisch aktiviert oder anderweitig angesprochen wird, was zum selben Fehler führt.
Ich berichte.

P.S: Danke Guru für deine Rückmeldung, der zweite Punkt war wegweisend!