AMD HD6450: 3D-Anwendungen verursachen schwarzen Bildschirm

15 Beiträge / 0 neu
Letzter Beitrag
meldrian
Bild des Benutzers meldrian
Offline
Beigetreten: 12.05.2009
Beiträge: 1649
AMD HD6450: 3D-Anwendungen verursachen schwarzen Bildschirm

Situation:
Neue Grafikkarte für den WohnzimmerPC gekauft (AMD HD 6450), propritäre Treiber von AMD draufgetackert (Ubuntu 10.04 bietet über Hardware keine an), alles wunderbar soweit. Starte ich ein Spiel (urban terror, nexuiz) wird der Monitor schwarz. Ende.
Starte ich OpenRa, welches sich im Fenster öffnet wird dessen Fenster schwarz. Starte ich red eclipse hängt sich das Spiel bei der Initialisierung von "GL" auf.
Recherchen im WWW waren soweit wenig hilfreich da meist veraltet oder andere Situation.
Was kann ich tun?

Freue mich wie immer über jede Hilfe.

Linux Gamer 91
Bild des Benutzers Linux Gamer 91
Offline
Beigetreten: 09.10.2010
Beiträge: 735

Probier mal das hier: http://wiki.ubuntuusers.de/Grafikkarten/ATI/fglrx/Problembehebung

Guru
Bild des Benutzers Guru
Offline
Beigetreten: 15.04.2011
Beiträge: 45

Hi!

Die AMD-Treiber sind seit jeher vor allem für eins bekannt: Probleme. Und unter Linux ist die Sache leider noch schlimmer als unter Windows.
Aber du könntest Folgendes versuchen:
- Treiber von der Homepage deinstallieren (fglrx-uninstall.sh - oder so ähnlich - sollte sich irgendwo finden lassen)
- Das x-swat-repository einbinden: sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
- sudo apt-get update
- sudo apt-get upgrade
- sudo apt-get install fglrx-installer

Damit wird der X-Server aktualisiert und der Treiber installiert. Das sollte helfen, weil Lucid ein paar Probleme mit dem vorhandenen X-Server in Verbindung mit dem Catalyst hatte.

meldrian
Bild des Benutzers meldrian
Offline
Beigetreten: 12.05.2009
Beiträge: 1649

Hi Ubuntu-Gaming,
die Schritte der Problembehandlung bin ich soweit logisch erfolgreich durchgegangen. Keine Besserung. Trotzdem danke für den Hinweis auf die Seite.

Hi Guru,
ich werde dein Vorgehen mal testen wenn ich etwas Zeit dafür finde (bin gerade Umzugshelfer). Ergebnis dann in Kürze hier.

Davon ab, entgegen meinen Erwartungen brachte das Downgrade von *.17 auf *.14 keine Besserung. Lediglich der Mauszeiger-friert-in-rechter-unterer-ecke-ein-Fehler lies sich damit effektiv beheben.

meldrian
Bild des Benutzers meldrian
Offline
Beigetreten: 12.05.2009
Beiträge: 1649

So, nach rumprobieren ein zwischenbericht.
Hab mich jetzt auf Ubuntu 11.04 hochgezogen. Die Treiber kommen jetzt direkt von Ubuntu, der Fehler bleibt aber bestehen (Treiber entspricht der *.14 Version).
Ich habe etwas interessantes bemerkt. Deaktiviere ich "Wait for vertical refresh" gänzlich, funktioniert glxgears nicht mehr.
Aktiviere ich es, funktioniert es wieder tadellos.
Ist das nicht vielleicht eine heisse Spur? Das scheint die URsache zu sein, die Einstellung "Wait for vertical refresh" im Ati-Treiber.
Aber warum? und warum gehen einige Dinge (glxgears) mit der einstellung und andere (urbanterror) weiterhin nicht?
Am merkwürdigsten verhält sich red eclipse. Startete das Spiel vorher gar nicht, komme ich mit "Wait for vertical refresh" bis in ein Onlinegame. Dann stirbt die Anwendung. Es ist also besser geworden aber immer noch bescheiden.
VSync ist ingame aktiviert.

manuel
Bild des Benutzers manuel
Offline
Beigetreten: 19.05.2008
Beiträge: 245

Hi Meldrian,

Kannst du die Karte nicht zurück geben ? Wegen nicht funktionsfähiger Treiber, kannst du sie ja nicht benutzen. Wenn dein Händler das akzeptiert, Blödi Markt ist da eigentlich kulant, wenn du die von da hast. Mit dem Geld kaufts du dir dann bitte eine Nvidia Karte,

Ich habe ein T400 Laptop und wollte mir bei der Anschaffung 200€ sparen und hab deshalb n ati karte. Die 200 sind den Stress nicht wert.!! Nvidia ist die einzige wahl mit Linux. Punkt. Ich grade jetzt auch wieder meinen Desktop Rechner ab, natürlich mit nvidia. Mit meiner ATi gibts zum Beispiel grafik Fehler bei X2 und Oblivion mit wine.

Kann dir zu deinem Problem mit ATI leider nicht weiter helfen aber ich hab auch einige mit den Treibern.....

Linux Gamer 91
Bild des Benutzers Linux Gamer 91
Offline
Beigetreten: 09.10.2010
Beiträge: 735

Also, ich habe ein Notebook mit Radeon Mobility HD 5650 mit Catalyst 11.8 (fglrx).

Meine Spiele (Trine, Amnesia: The Dark Descent, BEEP, Braid, Cogs, Oil Rush, World of Warcraft via Wine) und einige weitere laufen ohne Probleme. Trackmania United Forever läuft bis auf einige Grafikfehler auch noch gut.

meldrian
Bild des Benutzers meldrian
Offline
Beigetreten: 12.05.2009
Beiträge: 1649

Gut, jetzt nach einer unnützen Neuinstallation möchte ich gerne eine Kaufwarnung für Linuxspieler herausgeben

Finger weg von der ATI Radeon HD 6450.
Das Internet konnte mir bei meinem Problem leider nicht helfen und alle von mir getesteten Treiber brachten keine Besserung des oben beschriebenen Problems.
Um den Kern einzugrenzen: Eine Radeon HD 6450 scheint auf einem Ubuntu 10.04 - 11.04 nicht zum Spielen / generell für openGL-Anwendungen zu taugen. Selbst glxgears stürzt ab. SDL-Anwendungen funktionieren (teilweise). Ich kann natürlich nicht für kommende oder andere Distributionen sprechen. Auch will ich nicht ausschließen dass das Problem nur bei Gainward-Karten auftritt und andere Hersteller funktionierende Karten liefern würden.
Sollte sich mit zukünftigen Treibern von ATI/AMD oder mit einer neuen Distro das Problem gelöst haben, liest man es hier.

Desti
Bild des Benutzers Desti
Offline
Beigetreten: 09.09.2009
Beiträge: 112

Hast du auch mal eine nicht *buntu basierte Live CD probiert?

Guru
Bild des Benutzers Guru
Offline
Beigetreten: 15.04.2011
Beiträge: 45

Hi!

Das ist ja echt ärgerlich, dass die Spiele mit fglrx (noch) nicht laufen. Da heißt es wohl wirklich abwarten.
Wie sieht es denn mit den freien Treibern aus? Funktionieren die mit dem Chipsatz?

Commandline
Bild des Benutzers Commandline
Offline
Beigetreten: 23.05.2008
Beiträge: 313

@ Guru

Ich, für meinen Teil, warte schon seit knappen 9 Jahren auf einen Funktionierenden Treiber von ATI/AMD....... No Luck so far :/
Nvidia brachte dann die Lösung...........

Das mit einer anderen Distro wäre vielleicht mal nen Versuch wert........ Fedora vielleicht mal....

Guru
Bild des Benutzers Guru
Offline
Beigetreten: 15.04.2011
Beiträge: 45

@Commandline
Das klingt ja alles andere als vielversprechend. :(
Ich setze auch auf nvidia, die haben das mit den Treibern insgesamt eindeutig besser im Griff. Und was bringt die beste Grafikkarte, wenn die Treiber Murks sind?

Ich befürchte, dass eine andere Distribution keine großen Veränderungen bringen wird. Der Treiber behält seine Probleme und so verschieden sind die einzelnen Distributionen auch wieder nicht. Aber versuchen kann man es natürlich. ;)

meldrian
Bild des Benutzers meldrian
Offline
Beigetreten: 12.05.2009
Beiträge: 1649

So, nach langer Pause hatte ich genügend Motivation um einen Versuch mit OpenSuse 11.4 KDE zu wagen.
Live booten ohne Anpassung auf "vesa" wollte er schonmal gar nicht, dafür lief die Installation dann ohne Murren.
Kurzum: Ati-Treiber drauf, GLXgears gestartet, die Zahnräder bleiben hängen wenn ich die Maus bewege bzw. glxgears friert ein.
Hatte bis jetzt keinen 3D-Titel zur Hand (lade gerade xonotic 0.5), glaube aber dass das Fehlerbild distributionsunabhängig ist.
Ich gebe nicht auf und werde ab und an sicherlich nochmal die ein oder andere Betriebssystem und Treiberkonstellation probieren.
Alles weitere liest man dann hier.
Ich nehme selbstverständlich weiterhin gerne jeden Tipp und Rat an und probiere Vorschläge durch wenn diese erfolgversprechend sind.

Cheers,

Linux Gamer 91
Bild des Benutzers Linux Gamer 91
Offline
Beigetreten: 09.10.2010
Beiträge: 735

Probier es mal mit dem neuen Catalyst 11.9 Treiber: http://www.linuxgaming.de/hardware-peripherie-f130/amd-catalyst-11-9-erschienen-t5193.html

derkranich
Bild des Benutzers derkranich
Offline
Beigetreten: 20.07.2010
Beiträge: 32

mit der Radeon HD6850 funktionieren die FirePro treiber ganz ordentlich. allerdings bei mir mit mandriva 2010.2 (kernel 3.0.3)

Mastodon