Probleme bei Vollbildmodus bei portierten Spielen

15 Beiträge / 0 neu
Letzter Beitrag
Micha1711
Bild des Benutzers Micha1711
Offline
Beigetreten: 27.09.2009
Beiträge: 15
Probleme bei Vollbildmodus bei portierten Spielen

Hallo,

ich habe mir einige Demos von LPG portierten Spielen installiert.
Beim Umschalten in den Vollbildmodus habe ich das Problem, dass immer der untere Rand abgeschnitten wird und die Spiele dadurch unspielbar werden (da ja ein Teil fehlt). Aufgefallen ist es mir bisher bei den Demos zu Jets'n'Guns und Shadowgrounds.

Ich nutze OpenSUSE 11.1 mit Nvidia-Treiber. Der Bildschirm ist ein Ilyama-TFT mit einer Auflösung von 1280x1024.

Wie kann ich das Problem abstellen?

Danke!

Grüße

Michael

manuel
Bild des Benutzers manuel
Offline
Beigetreten: 19.05.2008
Beiträge: 245

Hi

Du kannst bei LPG Spielen und Demos den Fenstermodus erzwingen. Enfach in der hilfe nachsehen

Cu

MS

Micha1711
Bild des Benutzers Micha1711
Offline
Beigetreten: 27.09.2009
Beiträge: 15

Hallo Manuel,

beim Fenstermodus ist das Fenster viel zu klein, daher wollte ich ja unbedingt im Vollbildmodus spielen.
Gibt es eine Tastenkombination, wie ich mit dem Mauscursor wieder aus dem Fenster komme. Dann könnte ich mal probieren, dass Fenster größer zu ziehen. Oder kann man beim Starten vorgeben, wie groß das zu öffnende Fenster sein soll?

rettichschnidi
Bild des Benutzers rettichschnidi
Offline
Beigetreten: 13.05.2008
Beiträge: 1413

Für JnG gibt es nur eine Auflösung: 800x600

Kannst du mal sagen was dir

xrandr

ausspuckt?

Micha1711
Bild des Benutzers Micha1711
Offline
Beigetreten: 27.09.2009
Beiträge: 15

Hallo,

erhalte folgende Ausgabe:

michael@linux-2vhq:~> xrandr
Screen 0: minimum 320 x 240, current 1280 x 1024, maximum 1280 x 1024
default connected 1280x1024+0+0 0mm x 0mm
   1280x1024      50.0*    54.0
   1152x864       51.0
   1024x768       52.0     56.0     57.0
   800x600        53.0     59.0     60.0     61.0     62.0     63.0
   1280x960       55.0
   832x624        58.0
   640x512        64.0     65.0
   640x480        66.0     67.0     68.0     69.0
   576x432        70.0
   512x384        71.0     72.0     73.0
   416x312        74.0
   400x300        75.0     76.0     77.0     78.0
   320x240        79.0     80.0     81.0

rettichschnidi
Bild des Benutzers rettichschnidi
Offline
Beigetreten: 13.05.2008
Beiträge: 1413

800x600 ist mal dabei, gut.

funktioniert es mit

xrandr -s 800x600; jets; xrandr -s 0

Micha1711
Bild des Benutzers Micha1711
Offline
Beigetreten: 27.09.2009
Beiträge: 15

Wenn ich das aufrufe wird Jets'n'Guns im Fenstermodus bei 800x600 gestartet. Ich sehe am oberen Rand noch den Rahmen des Fensters. Der untere Rand bzw. die unteren Grafiken sind komplett weg.

rettichschnidi
Bild des Benutzers rettichschnidi
Offline
Beigetreten: 13.05.2008
Beiträge: 1413

Sorry, ich weiss nicht mehr weiter. Dein Problem scheint mir _sehr_ speziell zu sein.

Aber was heisst eigentlich die "untere Grafik"? Hast du ein Screenshot davon? (würde mich einfach wundern)

Micha1711
Bild des Benutzers Micha1711
Offline
Beigetreten: 27.09.2009
Beiträge: 15

Screenshot muss ich mal machen. Mit "untere Grafik" meine ich, dass das Spiel unterhalb des sichtbaren Bereichs des TFT weitergeht. Das praktisch ein Teil der Grafik, sprich der untere, fehlt. Wenn ich das Raumschiff bei Jets'n'Guns nach unten steuere, dann ist es nicht mehr sichtbar.

rettichschnidi
Bild des Benutzers rettichschnidi
Offline
Beigetreten: 13.05.2008
Beiträge: 1413

Da scheinen noch andere den gleichen Fehler zu haben. Der Kayman aus dem #lgp-Channel hat den Fehler auch bei JnG, nicht aber bei Shadowgrounds.
Hier sein Screenshot: http://img180.imageshack.us/img180/427/test01p.jpg

Hast du evt. Compize oder Co an?

Micha1711
Bild des Benutzers Micha1711
Offline
Beigetreten: 27.09.2009
Beiträge: 15

Ich habe es auch schon mit deaktiviertem Compize probiert. Das ändert aber leider nichts.
Anhand des obigen Screenshots kann ich es dir sehr gut erklären. Also den breiten oberen Rand habe ich
bei Vollbildmodus auch. Der untere schwarze Rand und noch ein kleiner Teil mehr, ist allerdings abgeschnitten.
Den "quit game" button kann ich schon nicht mehr sehen.

Vielleicht liegt es an den Nvidia-Einstellungen?
Blöde Frage: könnte es auch daran liegen, dass ich den TFT via DVI-Kabel am PC angeschlossen habe?
Seitdem ich ihn nach dem Umzug ausschließlich über DVI laufen lasse, kann ich am TFT-Panel z.B. auch
den Kontrast nicht mehr verstellen (nur noch im Nvidia-Programm). Auch das TFT OnScreen Menu erscheint
nicht zentriert sondern am rechten Rand und ist zum Teil abgeschnitten.

EDIT: Hab jetzt ein nicht ganz zufriedenstellende Lösung gefunden. Jets'n'Guns läuft z.B. unter einer Auflösung von 800x600. Wenn ich nun bei den Nvidia-Einstellungen die XScreen-Auflösung auf 832x624 einstelle und dann Jets'n'Guns im Fenstermodus ausführe, dann ist es "fast" Vollbild, allerdings mit den ekligen Fensterrahmen bzw. -leiste. Das ist nicht ganz so schön.

manuel
Bild des Benutzers manuel
Offline
Beigetreten: 19.05.2008
Beiträge: 245

Hi Micha1711

Dafür hab ich eine lösung.

Führe das Spiel mit xgame in einem neuen xserver aus und setze dort ein schwarzes hintergrundbild.

Da du es in einem neuen Xserver ausführst hat dieser keinen Fensterkontrollmanager also keine Fensterleiste und das Spiel erscheint einnfach so ohne störende Fensterleiste. Das hintergrundbild ist wichtig da du sonst den default xserver minischachbrettmuster hintergrund hast und der ist fast weiß, was ich als störend empfinden würde.

xsetroot -solid black

Viel spass mit JNG

Manuel

Micha1711
Bild des Benutzers Micha1711
Offline
Beigetreten: 27.09.2009
Beiträge: 15

Hallo Manuel,

danke für den Tipp, aber ich stehe grad ziemlich auf der Leitung... ?!?!

Wie und was muss ich genau machen?

Danke!!!!!!!!!!

manuel
Bild des Benutzers manuel
Offline
Beigetreten: 19.05.2008
Beiträge: 245

Hi

Besorg dir xgame

-->http://freshmeat.net/projects/xgame/

mach es ausführbar und kopiere es nach /usr/local/bin

Gehe in den jng folder und kopiere das startscript annahme jng zu jng_neu , öffne es und schreib in die oberste zeile "sudo xsetroot -solid black" (nach #!..... also eine zeile darunter), abspeichern

öffne /etc/suoders mit visudo und trage in die letzte zeile ein:

<dein benutzername> ALL=NOPASSWD:/usr/bin/xsetroot

speichere die datei ab.

starte eine konsole und Tippe xgame ein drücke enter

drücke A , tippe einen namen ein drücke enter tippe den pfad zum executeable von jng_neu ein drücke enter

beende xgame und starte es neu

drücke 1 um jng zu starten.

Es kann sein das es dir nicht erlaubt ist einen neuen xserver zu starten dann führe den befehl aus und wähle "jeder" oder "all"

dpkg-reconfigure xserver-common

upps da du ja suse hast die einstellung steht in /etc/X11/Xwrapper.config (glaub ich)

Viel spass

Manuel

Micha1711
Bild des Benutzers Micha1711
Offline
Beigetreten: 27.09.2009
Beiträge: 15

Hab "fast" alles geschafft. Aber ich finde ehrlich gesagt kein Startscript für Jets'n'Guns...nur ein ausführbares Programm jets_demo.

Hab eine neue xorg.conf gebastelt und die Auflösung geändert. Allerdings lässt sich der XServer tatsächlich nur als Root vernünftig starten, weil ich sonst Fehlermeldungen im Spiel (Sound, etc... erhalte).

Mastodon